CVE-2025-54988Tika XXE
Apache Tika XXE Vulnerability via Crafted XFA File Inside a PDF
Published Aug 20, 2025 · Updated Oct 28, 2026 · Also known as DEBIAN-CVE-2025-54988, DLA-4350-1, GHSA-p72g-pv48-7w9x, ROOT-APP-MAVEN-CVE-2025-54988, UBUNTU-CVE-2025-54988, USN-8324-1
Key Facts
Patch immediately- CVE-2025-54988 is a critical-severity vulnerability (CVSS 9.3 v4) affecting Tika (Apache), elasticsearch-8.17 (chainguard), elasticsearch-8 (chainguard) and 12 more products.
- It is exploited in the wild, listed in Industry KEV feed since Oct 28, 2026. A public exploit is reported by tracking sources, but no code link is listed yet.
- EPSS estimates a 48% probability of exploitation in the next 30 days.
- Fixed versions are available, including Tika 3.2.2, Tika 1.22-1ubuntu0.1~esm2, Tika 1.22-2+deb11u1.
- Brandefense priority: patch immediately, because it is listed as exploited in the wild.
Scores
CVSS v4
9.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
EPSS (30-day exploit likelihood)
48%
Higher than 98.8% of all scored CVEs
Exploit maturity
Exploited (KEV)
ATLAS score
61/100
Publication score, see How it works
Exploitation Verdict
KEV listed
Oct 28, 2026
434 days after publication
Federal due date
None
No federal due date
Ransomware use
Not reported
Attributed actors
None named
Exploit & Defence Guidance
Exploit maturity
Exploited (KEV)
Public exploit code
0
Proof-of-concept links
In-the-wild evidence
1
Reports of active use
Advisories And Exploit References
- advisoryhttps://www.cve.org/CVERecord?id=CVE-2025-54988
- advisoryhttps://nvd.nist.gov/vuln/detail/CVE-2025-54988
- advisoryhttps://security-tracker.debian.org/tracker/CVE-2025-54988
- advisoryhttps://ubuntu.com/security/CVE-2025-54988
- advisoryGHSA advisory
- advisoryhttps://github.com/apache/tika/commit/bfee6d5569fe9197c4ea947a96e212825184ca33
Description
Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers.
Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard.
Users are recommended to upgrade to version 3.2.2, which fixes this issue.
Known-Exploited Catalog Listings
| Catalog | Added | Remediation due | Ransomware use |
|---|---|---|---|
| Industry KEV feed | Oct 28, 2026 | n/a | Not reported |
Affected Products
34 affected entries in total| Product | Affected versions | Fixed in |
|---|---|---|
| TikaApache | See advisory | 3.2.2 |
| elasticsearch-8.17chainguard | See advisory | 8.17.10-r1 |
| elasticsearch-8chainguard | See advisory | 8.19.2-r1 |
| elasticsearch-fips-8chainguard | See advisory | 8.19.2-r3 |
| elasticsearch-fips-9.0chainguard | See advisory | 9.0.8-r0 |
Patched Releases
Tika
3.2.2, 1.22-1ubuntu0.1~esm2, 1.22-2+deb11u1, 1.22-2+deb11u1build0.22.04.1
apache-tika-3.0
3.0.0-r5
apache-tika-3.1
3.1.0-r5
elasticsearch-8
8.19.2-r1, 8.19.3-r0
elasticsearch-8.17
8.17.10-r1
elasticsearch-9.1
9.1.4-r0
elasticsearch-fips-8
8.19.2-r3
elasticsearch-fips-9.0
9.0.8-r0
elasticsearch-fips-9.1
9.1.2-r12
io.root.org.apache.tika:tika-parser-pdf-module
2.9.2-root.io.3, 2.9.2-root.io.4, 2.9.2-root.io.5, 2.9.2-root.io.6, 2.9.3-root.io.1, 2.9.3-root.io.2
libtika-java
1.22-1ubuntu0.1~esm2, 1.22-2+deb11u1build0.22.04.1
opensearch-2
2.19.4-r0
opensearch-3
3.3.0-r0, 3.3.2-r0
org.apache.tika:tika-parser-pdf-module
3.2.2
org.apache.tika:tika-parsers
2.0.0-ALPHA
Timeline
Publicly disclosed
Aug 20, 2025
Added to Industry KEV feed
Oct 28, 2026
Last updated
Oct 28, 2026
Weakness Type
- CWE-611 Improper Restriction of XML External Entity Reference
References
- advisorycve.org · CVERecord
- advisorynvd.nist.gov · CVE-2025-54988
- advisorysecurity-tracker.debian.org · CVE-2025-54988
- advisoryubuntu.com · CVE-2025-54988
- advisoryGHSA advisory
FAQ
Common Questions.
Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF.
Affected: Tika (Apache); elasticsearch-8.17 (chainguard); elasticsearch-8 (chainguard), among others. The full list is in the CVE brief.
It is exploited in the wild, listed in Industry KEV feed since Oct 28, 2026.
No, it is not currently listed in the CISA Known Exploited Vulnerabilities catalog.
A public exploit is reported by tracking sources, but no code link is listed yet.
Fixed versions are available, including Tika 3.2.2, Tika 1.22-1ubuntu0.1~esm2, Tika 1.22-2+deb11u1.
Brandefense priority: patch immediately, because it is listed as exploited in the wild.
Is CVE-2025-54988 On Your Attack Surface?
Brandefense matches it against the products discovered on your perimeter and opens a finding the day a CVE like this is listed.
Request A Demo